Killing floor problem, need help please!

I am a computer newb/noob, I know next to nothing about how to do most things on one. So here we go ...

I go onto killing floor, click on a game, join up, click ready, then I am a spectator and watch zombies walk into walls / I am playing but nothing is moving including other players.

I can press ESC to enter the menu were I can choose to be a spectator, I can press tab and it shows my ping is between 500 and 650 but I did an internet speed test and it told me it was 43.

I have verified the files on steam.

Any advice on whats happening or how to fix it (step by step guides would be greatly appreciated) is very welcome!

Thanks guys and gals.

Make sure your firewall isn't blocking the game.

The ping is dependent on the server.

Open ports on your router.

When looking at the list of servers, arrange them by ping, and only join ones with a ping of below 100. If there are none, then I really wouldn't know what to suggest.

Jaranja:
Make sure your firewall isn't blocking the game.

The ping is dependent on the server.

Open ports on your router.

How do you do any of that? Yeah, I am that much a idiot when it comes to computers.

Frequen-Z:
When looking at the list of servers, arrange them by ping, and only join ones with a ping of below 100. If there are none, then I really wouldn't know what to suggest.

I have joined games with a ping of 300 odd and games with a ping of 50 odd.

Another little side note, I was playing fine yesterday for a good few hours.

I have just gotten this message.

"Please make sure universal plug and play is enabled, or the ports 7707 UDP, 7708 UDP, 7717 UDP, 28852 TCP & UDP, 8075 TCP and 20560 TCP & UDP are opened on your router/firewall."

Basically, umm what? I have no idea what any of that means and I don't want to aimlessly change things 'cos thats when shit goes bad.

Edit. Sorry should have changed my other post.

>.<

omega 616:
I have just gotten this message.

"Please make sure universal plug and play is enabled, or the ports 7707 UDP, 7708 UDP, 7717 UDP, 28852 TCP & UDP, 8075 TCP and 20560 TCP & UDP are opened on your router/firewall."

Basically, umm what? I have no idea what any of that means and I don't want to aimlessly change things 'cos thats when shit goes bad.

Do you have a router?

If so, you'll have to go onto http://www.portforward.com

You click on Router list, find one with your model number, find the game, KF in this case, and follow the instructions.

did you try googleing the error message? chances are someone else somewhere has already asked this question and other people have already explained how to fix it. This is how I solve most of my computer related problems and any problems that people bring to be because I'm the"computer guy" of the family...If they only knew.

Jaranja:

omega 616:
I have just gotten this message.

"Please make sure universal plug and play is enabled, or the ports 7707 UDP, 7708 UDP, 7717 UDP, 28852 TCP & UDP, 8075 TCP and 20560 TCP & UDP are opened on your router/firewall."

Basically, umm what? I have no idea what any of that means and I don't want to aimlessly change things 'cos thats when shit goes bad.

Do you have a router?

If so, you'll have to go onto http://www.portforward.com

You click on Router list, find one with your model number, find the game, KF in this case, and follow the instructions.

I have got up to were it says enter those numbers but it only lets me choose either UDP or TCP and none of the numbers come in two parts.

Thanks for all your help! You are legend!

EDIT. http://portforward.com/english/routers/port_forwarding/BT/BTHomeHub2/default.htm

I am near the bottom were it's got "If you are forwarding a single port, enter that port number into the Left Port Range, Left Translate To and the Right Port Range, Right Translate To boxes. If you are forwarding a range of ports, enter the lowest number of that range into the Left Port Range, Left Translate To box. Then enter the highest number of that range into the Right Port Range, Right Translate To box."

Brain over load!

your speed can be as high as you want, if the server you play on is slow it won't help you. Find a server that give's you a ping ideally >100 but if its lower than 150 it should be ok.

You can check the ping of a server BEFORE joining a game ;) try setting low ping servers as a priority so the fastest servers apear at the top of your list

hope that helps

tris4992:
your speed can be as high as you want, if the server you play on is slow it won't help you. Find a server that give's you a ping ideally >100 but if its lower than 150 it should be ok.

You can check the ping of a server BEFORE joining a game ;) try setting low ping servers as a priority so the fastest servers apear at the top of your list

hope that helps

Apparently it's down to my ports which I am trying to open but the site I am using for help has made my brain melt!

omega 616:

tris4992:
your speed can be as high as you want, if the server you play on is slow it won't help you. Find a server that give's you a ping ideally >100 but if its lower than 150 it should be ok.

You can check the ping of a server BEFORE joining a game ;) try setting low ping servers as a priority so the fastest servers apear at the top of your list

hope that helps

Apparently it's down to my ports which I am trying to open but the site I am using for help has made my brain melt!

forget about the ports, I also sometimes get it but it never has anything to do with the ports (keeping in mind I have 200+ hours on the game I don't think I'm wrong)

Make sure you have the latest version of the game (just check it on steam,I'm assuming you bought it on steam) , make sure your video and soundcards are up to date (you can do that by going to the website's of the respective producers), And if all else fails reinstall the game

trust me its NEVER, EVER the ports :p

tris4992:

omega 616:

tris4992:
your speed can be as high as you want, if the server you play on is slow it won't help you. Find a server that give's you a ping ideally >100 but if its lower than 150 it should be ok.

You can check the ping of a server BEFORE joining a game ;) try setting low ping servers as a priority so the fastest servers apear at the top of your list

hope that helps

Apparently it's down to my ports which I am trying to open but the site I am using for help has made my brain melt!

forget about the ports, I also sometimes get it but it never has anything to do with the ports (keeping in mind I have 200+ hours on the game I don't think I'm wrong)

Make sure you have the latest version of the game (just check it on steam,I'm assuming you bought it on steam) , make sure your video and soundcards are up to date (you can do that by going to the website's of the respective producers), And if all else fails reinstall the game

trust me its NEVER, EVER the ports :p

I was playing the thing fine yesterday then, without changing a thing, I am constantly a spectator.

omega 616:
I am a computer newb/noob, I know next to nothing about how to do most things on one. So here we go ...

I go onto killing floor, click on a game, join up, click ready, then I am a spectator and watch zombies walk into walls / I am playing but nothing is moving including other players.

Ok, I had this problem. What's happening is that your connection is too slow to pre-cache all the monsters so it's falling off. Nip into the .ini file in Killing Floor and change all the "Cache" settings to False.

That should fix it.

Then change them back to True one at a time and see which one causes the drop outs. You WILL suffer from random pauses when it spawns a new monster type, but one of the Caches will fix that.

BTW, you do know there is an Escapist killing floor server? Run by the Team Fortress 2 brigade. Join up to our group and we'll be posting games to play every so often.

Edit: This may also help

The_root_of_all_evil:

omega 616:
I am a computer newb/noob, I know next to nothing about how to do most things on one. So here we go ...

I go onto killing floor, click on a game, join up, click ready, then I am a spectator and watch zombies walk into walls / I am playing but nothing is moving including other players.

Ok, I had this problem. What's happening is that your connection is too slow to pre-cache all the monsters so it's falling off. Nip into the .ini file in Killing Floor and change all the "Cache" settings to False.

That should fix it.

Then change them back to True one at a time and see which one causes the drop outs. You WILL suffer from random pauses when it spawns a new monster type, but one of the Caches will fix that.

BTW, you do know there is an Escapist killing floor server? Run by the Team Fortress 2 brigade. Join up to our group and we'll be posting games to play every so often.

Edit: This may also help

IT WORKED!

Thank you so much! And everybody else who helped.

Edit again. It worked for one game!

 

Reply to Thread

This thread is locked