Google nexus 7 play store error (495)

Greetings,
I recently bought a nexus 7 and for the first few weeks it was all fine and dandy, I could download and update whatever I wanted and whenever I wanted to, however recently this has all changed. Whenever I try and download something, the download doesn't start and after a while of trying it will give up with the line "update for "" could not be downloaded due to an error. (495)".
I have tried:
A factory reset, which was a successful solution for 1 download (minecraft) before the old problems came back.
Clearing caches, data and forcing stops on related apps.

My router: Draytek Vigor2600V series annex A

Cheers x

Hm... this: http://android.stackexchange.com/questions/23055/what-is-error-code-495-on-google-play-and-the-youtube-app gives several answers you could try.

Also:

Had a S3 today that would not download applications from the Play store, managed to fix it by going to Accounts & sync -> Google and turning "Sync Gmail" off and then back on again, then after restarting the phone it worked.

from: http://crowdsupport.telstra.com.au/t5/Android/Can-t-download-from-Google-Play-store-over-3G-NextG-Error-495/td-p/69502

And:

Install ES File Explorer and search in the upmost file system (known just as "/" ) for junk files of the apps you're trying to install. Also search for hidden files (these begin with a dot before the name, so .<file> ).

You can delete or rename these, that could solve the problem.

http://www.android-hilfe.de/samsung-galaxy-s3-i9300-forum/281780-nicht-genuegend-speicherplatz-verfuegbar-mit-sgs3-stock-rom.html

The last solution is for a different error but might also work for yours.

I also had the infamous "error 495" on my Samsung Galaxy S2 running Android 4.0.4. I searched for 4 or 5 hours online, cleared my app cache, un-updated Google Play (it didn't work and completely uninstalled it; fortunately, it reinstalled without a problem), stopped the Play service, etc etc etc and rebooted about 12 times. After reading some forums, it seemed that the time of the device and the network could have played a role. Indeed, it might have stopped working after I left the US to Europe and now India.

What was really weird is that *some* apps would install or update but most would not. The green bar would move and move but without any progress or indication of what was happening.

I also lost some time because my system partition is almost full and I thought it was that. It turns out it's close to impossible to remove anything in it (and is it possible/desirable?)

The only way I found to manage to start updating apps is to make it believe that it was in the US... I set the time to US EST, and connected to a US VPN. It started updating one of my apps, albeit so slowly that the VPN cut before it could finish... I need to try again with a paid VPN... :(

Why would my phone not update when I'm outside the country? Is it Google or AT&T? Is there any setting that I can change? What are the workarounds? Connecting to the VPN every time is not very practical...

By the way, and I don't know if it's connected or not, my GPS works very poorly abroad - any suggestion?

 

Reply to Thread

This thread is locked