Can anybody tell me whats wrong with my pc?

OKAY I have a Hardware issue that has left me very confused and desperate. I decided to upgrade my computers case, Motherboard, and psu. My old system is:
Psu coolermaster 460w
MOBO Asus M4A785TD-M EVO
Gpu Saphire hd5770
4gb GSKILL (4sticks of 1gb)
CPU amd phenom 2 b980 (quadcore at 3.7ghz)
crappy roswill case
hitachi 7200rpm hdd and seagate 7200rpm hdd
My pc kept crashing and i was convinced it was the mobo
I bought
Thermtake v4 ATX case
msi 970A-G43
coolermaster 700 w extreme.

During putting together the new pc I had my CPU stuck to the heatsink and spent an hour trying to get the damn thing off. I tried putting rubbing alchol on it. Now I read online that WD40 could help (I know, I'm dumb) and tried that and actually ended up getting it on my cpu pins. I freaked out of course and tried to get it off with my blowdryer and dust off. Anyway I got it off with pliers (yup.) and finally put it together. It wouldnt post. I made sure i didnt miss any of the basics. 12v connector was there ram was in right cpu in right yada yada. Now I decided to see if it was the cpu by putting it back in my old system. I rebuilt my old system and it worked! So I figured it was the MOBO that was broken. I hooked everything back up and booted up my old system and got to the desktop. Now I noticed that my Front case usb wasnt working so I put my hand on the bluetooth dongle i had inserted there and noticed it was super hot! So i turned off the pc and realized I had accidently put the USB connector on the FIREWIRE slot. I went ahead and fixed that and turned my pc back on. NO POST. NO BIOS, power went on but I had no video no beeps either. NO beeps the first time either. So I unplugged my video card to see if that was the problem, i used the integrated graphics and no post. I replaced my cpu with my old anthlon 2 one. NO POST. I have no idea what is wrong. Are both mobos damaged, did i short out my old motherboard somehow? Can anybody help me here, because I would really like to get my system up and running asap! Thank you for reading!

From what I can gather, phenom 2 b980 isn't a thing, though whether your CPU is supported by the new board is probably the least of your worries. You've committed some terrible atrocities and it seems like you might have to pay for it (pliers? REALLY?). Reseat everything on the original board (in the right place this time, keeping in mind that 1394 is not USB) and try to get it working again. If that doesn't work, put the new one back in and try that. If neither work then it's pretty much confirmed that you've killed something important and are completely screwed. That is all.

It seems that you got yourself a fried mobo from the looks of it, maybe even a broken CPU if the pins are bent.
But I guess it's important that you learned from your mistakes.

You definitely have broken your CPU. NEVER use force on a CPU. You have also probably fried at least one motherboard.

 

Reply to Thread

This thread is locked