Can't Access the Main Escapist Page?

Hey Guys,

So I've been having an issue accessing the main Escapist page online, I can access any links to various news stories, videos, and obviously the forums since I'm posting.
However, whenever I try going to the Escapist home page, I always end up with an HTTP Error 500, or an Internal Server Error. It started a few days ago and I let it slide thinking it was an error on this end, but according to a few other sites I've checked, the page is just down for me.

I've never had this issue before, and if it helps I'm running Chrome... any tips for fixing this?

500 errors are just what it says on the tin, an internal server error, meaning something broke server-side. They can be caused by something client side--an addon perhaps or malformed request.

Try another browser and/or disable some addons.

I just loaded the front page in Iron (Chromium-based) just fine.

evilneko:
500 errors are just what it says on the tin, an internal server error, meaning something broke server-side. They can be caused by something client side--an addon perhaps or malformed request.

Try another browser and/or disable some addons.

I just loaded the front page in Iron (Chromium-based) just fine.

Well I just downloaded Firefox and it opens fine... but I really dont want to have a separate browser just for this one page... any advice on how to fix this without uninstalling & re-installing Chrome?

Well that proves it's the browser. Try the usual clear cache and cookies (in Chromium I think it's Delete Browsing Data) and disable addons/extensions. Then, yes, reinstall if that doesn't work. Or free yourself from Google's evil clutches and switch browsers. Or download it without the Google infestation: http://www.portablefreeware.com/index.php?id=2169

 

Reply to Thread

This thread is locked