Portal 2 won't start for many people

http://forums.steampowered.com/forums/showthread.php?t=1847517

Anyone on the escapist aside from me who can relate to the people in this thread?

Nope! Mine worked fine. Runs really good too.

Same problem; won't start, though the process is appearing in my task manager.

Hurrah, I eventually got to Portal to start by following this advice and running Steam in Admin-mode (I'm on Vista). Had to repeat the deletions 3 times but it eventually started with Admin mode.

Originally Posted by SteveMac View Post
Fixed it.

For anybody having issues with the APPCRASH - BEX and dumping them out straight after the intro video.

Make sure you have the up to date Re-distributable files installed from Microsoft:
http://www.microsoft.com/downloads/e...f-9350143d5867

Close Steam (If it's running) and then delete the following two files (portal2.exe and client.dll) from here:

Code:

\Steam\steamapps\common\portal 2\portal2.exe
\Steam\steamapps\common\portal 2\portal2\bin\client.dll

Run Steam, Right click Portal 2 > Properties > Local Files > Verify Integrity of Game Cache.

Wait for that to finish and It'll re-download the two files.

Try and run Portal 2 (If you get Incomplete Installation (10) just re-run it a few more times as this isn't a problem)

Hope that helps for some people.

http://forums.steampowered.com/forums/showthread.php?t=1847560&page=44

I recommend going to the steam forums when you have problems with steam.

Edit: I saw your steam link. Not sure why you made this post here then. There's 80 pages on that thread.

Anyhow, no. My portal runs fine.

I installed it from disc, but I havn't touched it since.

From what I hear its apparently because Portal 2 uses a new form of Steam's DRM.

Wonder why they introduced new DRM. Because from what I hear, it did nothing to stop pirates.

Portal 2 installs great from dvd overhere. Didn't do much else.
After installing and initial updating, i started the game and... nothing. Just a black screen and i needed to hard reset my pc to get back to windows.
I removed all the data, and i downloaded the 11 gb of game files and will try another time tonight after i have installed the new display drivers.

 

Reply to Thread

This thread is locked