Alright, lets swap Skyrim glitch stories.

 Pages PREV 1 2
 

I can't buy a house in windhelm. When I ask the guy says there have been some unpleasantries, but I can't do the quest to solve the murders because I can't find the dead girl in the graveyarddd AARRGGHHHH.
Alduin had a missing texture when I fought him.
Every building in windhelm has no walls whatsoever.
Every time I go to windhelm there is a dragon.
Every time I fast travel there is a dead dragon flying out of the ground.
Arch mage had a missing texture.

This is still the best game I have ever played.

I currently have an arrow and an ice bolt sticking in me that don't want to go away. Its a little distracting when you have a giant glowing piece of ice stuck in your back while your trying to sneak around.

realist1990:
I got attacked by an invisible Khajiit. the only way i could kill him was I used the detect life shout..still not sure if it was meant to be a glitch or not.

I was under the impression that giants were supposed to send you into low-nirn orbit, it's happend to so many people I know I don't think it can be called a glitch

I've also been attacked by that khajiit, although I didn't have detect life so was flailing around in a circle looking for the red mark on the compass until it finally died. Was really disappointed with the loot, if it were fallout I'm sure there'd of been some form of unique item!

Found a bear while trying to get a werewolf totem. He died on the small iron bar on the ground and was stuck in a running in the same spot animation. Its Boscott the running dead bear.

That dragon lich that had the staff of magus got stuck behind a rock so i could just lob arrows at him and not be insta killed.

My Red Eagle mission is bugged and anytime i read a book about him the mission reopens and have to do everylittle thing again.

Not that theres anything wrong with this but when i made a return visit to the graybeards i found one getting a lap dance from the other.

Killed a dragon at the college of winterhold. Then the dancing dragon bug made him bitch slap the hell outta savos aren.

I am able to loot ghost before they vanish. Especally if you grab their weapons.

This is an annoying glitch: unable to use weapon racks or random weapons disappearing off of my wall. Namely the Skull of Corruption. STILL pissed about that.

My friend has been running into two glitches: 1) invisible enemies, 2) not absorbing dragon souls. It's baaaaad.

EDIT: Also, if you use Firebolt on a dragon's corpse, it goes FLYING. Soooo much fun!

After a solid 40+ hours without seeing a glitch (aside from two crashes to desktop), I fell through the floor of a cave and after about 10 seconds of falling, was teleported back to the entrance.

Watched a horse I stole levitate backwards, fly part-way up a cliff, then warp down the road a couple hundred feet.

One strange glitch I saw yesterday. I was exploring the plains and I came across a solitary deer. As I came closer the deer didn't run it just looked at me and I looked at it. It was a beautiful moment of connection between a lonely adventurer and a lonely animal, and then I buried my axe in its skull, skinned its corpse and went on my merry way. Any animal stupid enough not to run away from a man wearing furs and wielding an axe doesnt deserve to live.

Does this count as a glitch(source:rpgcodex) ?

image

LAWL at sexy glitches.

I've never been invited by giants to see Skyrim from above because I've let them milk their mammoths (or whatever it is they do) in peace.

However, as my computer isn't really up to date, I have a slight lag which has the weirdest effect upon gravity; whenever I ride downhill, it doesn't quite catch up and my horse will ride straight forward into thin air before sloooowly falling to the ground (sometimes 30 meters down) and die.
Same applies for my fellow Stormcloaks (two of which fell in stairs and died while we were looking for that crown) and Imperial Guards, who stepped off towers 20 meters tall and fell to their death in their haste to fight me.

Domehammer:
Enchanting table bug is probably worst I found. If I manage to scroll back while on enchanting table and then try to leave I go back to first person but am frozen in position to do enchanting and have to reload a save.

That has happened to me as well, but if I wait a little bit, it always fixes itself.

o.t. I ran into the backwards dragon over the weekend. Weird, he managed to kill a couple bandits, but never landed and I just gave up on killing him.

In a town I saw a small river have a texture glich as it would change its structure to a what looks like a beta test river grafic

AngleWyrm:
How to ride a horse

Ummm you forgot to add "like a boss."

On my first Skyrim character, there was always the same guy stuck in the ground outside of Whiterun.
Always.

He looked like he was sitting on a horse, except he was in the ground from his waist down.
He must be really lonely...

I was in the gloombound mine near windhelm getting Ebony when I bumped a cart with some ebony ore in it. An Ebony ore fel reight out of the ceiling. i did it again, and another ore appeared out of the ceiling. i did this for a few minutes, went outside, smelted it down, went and made daedric weapons and armor, and the stuff i made read 'Stolen' even though the Ebony ore and the ingots did not. then i fell out of the map and respawned in falkreath with my armor. I couldn't love this game more.

About half the times I try to lockpick, it sticks. Without touching the controller, the lock tries to unlock itself and breaks the pick. This repeats until I exit out. Sometimes, this will happen with multiple attempts. I'll exit out and try again, but it keeps doing it. If I wait a couple seconds, it's fine usually.

I also can't drop or store Finn's Lute or Pantaea's Flute. And the Wolf Queen quest refuses to start properly.

Right now, I'm currently having a freezing problem, where the game is freezing every time I try to load up my character. It's worrying me.

A group of the Imperial Legion Dance Group was moonwalking down the road with a Stormcloak Prisoner. After they pass me, the one at the rear stops and looks into my eyes. "Keep out of this" he says, before promptly levitating into the sky and disappearing into the clouds.

I will never forget Levitator and his Moonwalking Army.

once i found a horse who had buried his front half in the ground with just the arse sticking up from the ground somewhere outside the dark brotherhood sanctuary. i swear i am not making this up

This just happened to me a few minutes ago. I exist the Palace of Kings in Windhelm, having gotten permission to investigate the local murder. I take a step or two, when suddenly a dragon drops from the sky, lands back-first into the palace's courtyard, and disintegrates before my eyes. Um... 'kay... not that I'm complaining about the free soul and bodily remains, but that was... odd...

Recently, I was fighting a group of Forsworn, and whenever my character would do that special power attack that severs the opponent's head, the body would turn invisible as it fell to the ground. I'd still be able to loot it and move it around with the "grab" function, I just couldn't see it.

There was also that time I was fighting a dragon, who landed, as dragons often do, and spontaneously died even though he had plenty of health. I ended up being murdered by Forsworn soon after and having to reload a few times, and each time the same dragon would die the exact same way.

I went to an Imperial Camp to be greeted by two horses on top of each other. Not the dirty way, they made a plus sign. Strangest thing I've seen in Skyrim so far.

I've found two minor ones and a game-breaking one.

I got subtitles stuck when Karliah grunts. I just wandered around forever with "Unnghhhh" on my screen until somebody else spoke.

I killed a Khajit in Riften (not going to specify to avoid spoilers), and his tail wouldn't stop moving. It kept flopping around. I even took his body and moved it around, and his tail still kept flopping back and forth like it had a mind of it's own.

The game-breaking one happened in Helgen in the beginning of the game. I was rushing through it and I ran ahead of Ralof going instead the tower. The dragon busted through, and breathed fire like he was suppose to, then just stayed there. He wouldn't move out of the way so I could jump down. I climbed on top of the dragon but couldn't reach the inn below (I think his wings were in the way). Ralof was stuck in sneak mode on the stairs and wouldn't move. He kept just repeating his normal lines.

I gotta say, that bug scared the crap out of me when I turned on the stairs and had a dragon head just staring at me.

I got three weird ones, haven't heard of them before so they might be unique or whatnot.

The first is that I was in Riften, grabbing a bounty from a dragonslaying job, and as I approach Mistveil keep something most curious catches my eye. The castle walls are all gone. The doors are still there, just none of the walls. So, being the very serious person I am I saved my game... and ran through the un-walls... and fell out of Riften, I then spent the next hour running and shouting around a near-featureless Skyrim. Curiously, Odaving still came when called and I could still create a storm (no lightning strikes though). So after a while I grew bored, and infinitely lost, and reloaded my Riften save to find that the walls had been rebuilt.

The second, I found riotously hilarious. Alright, so my character already finished the companions, and got rid of werewolf status (I'm high level and I need the resting bonuses to get anywhere at this point). Anyways, I go to darkwater crossing to finish up the last bit of delivery sidequests for the npc residents. So, I walk out of the cordunum mine and what do I see but Skjor! Yes, good old dead Skjor... traveling slowly over the ground with invisible greatsword in hand and everything from his waist down merged into the land. So, I, out of intense curiosity, decide to follow him as he makes his painfully slow trip across Skyrim. Needless to say, it was an interesting trip, turns out that bandits are unable to attack handicapped zombies but the feeling isn't mutual when I watched him butcher a fort full of bandits without one of them raising a hand (invisibility potions for observation purposes). After a few hours of this (I found myself enthralled by him) I decided to test my luck and proceeded to murder him, as a vampire with a torch, at which point he vanished into nothingness.

One of my sub-characters joined up with the legion and ended up killing a fort full of stormcloaks, finding in the process the best invention ever. An alchemy table built into a workbench!

Short version:
1. Fell out of Riften and traveled the world of shapeless polygons.
2. Watched half of a dead nord werewolf ghost butcher bandits before killing him.
3. Alchemic workbench win.

My favorite glitch in Skyrim that I have encountered thus far has to be this:

So I was walking around the forest killing wolves to get leather for light armor because I was doing my stealth play through, when I discovered a peculiar table in the middle of no where. A bandit was sitting on one chair. The other chair? A dragon. Sitting up right. I don't know how, maybe the skin coding for bandit and dragon got switched, but I swear to christ I saw that, and it was amazing.

Right after I did the last companion quest, I got stuck behind some rocks, I swear to christ I was jumping for ten minutes before I got out of there.

My brother killed a dragon, but he couldn't absorb his soul for some reason.
As for myself, I was doing the Pelagius quest because Sheogorath is awesome, and the sultry maiden that appeared when you use your Wabbajack on the Hagraven would speak with a deep man's voice. I was also able to punch Pelagius the Tormented with my free hand, at which point he got up, said a line, and then went back to sleep. I think those two are easy to reproduce.
Also, kinda off-topic, but do you know who voices Mario- I mean Paarthunax?

I once fought a Dragon near a cliffside Hut.

The Hut was made of Straw and Wood yet seemed a sturdy structure to withstand the mighty flames of Hell.

As I whittled away his health, he loft into the air for his Final Aerial strike to which I reacted with an arrow toward his left Eye.

As my Glass Arrow shattered upon impact The Monster veered directly at my Sturdy Hut, Crashed into the Ground, and fell off the cliffside.

Unable to fly, the Beast succumbed to Fall Dmg and Died Gloriously.

 Pages PREV 1 2

Reply to Thread

This thread is locked