The Escapist User's Guide to Posting Commands and How to do Fancy Code Stuff

 Pages PREV 1 2
 

So I've added a couple of fancy code stuff, gonna add more eventually. If anyone else would like to share others that would be great.

Thanks to Barbas for showing how to resize YouTube videos. Apparently It's not as hard as I thought. >_<

[youtube=4qsWFFuYZYI height=400 width=600]

This was due for an overhaul although personally I think this should be stickied up front below the index.

Redlin5:
This was due for an overhaul although personally I think this should be stickied up front below the index.

Well, it's already in the index.

Wait... then how did you find this thread? Wait... do you mean this specific thread needs an overhaul? Wait... I don't even like anchovies.

I'm so confused.

Aerosteam:

Redlin5:
This was due for an overhaul although personally I think this should be stickied up front below the index.

Well, it's already in the index.

Wait... then how did you find this thread? Wait... do you mean this specific thread needs an overhaul? Wait... I don't even like anchovies.

I'm so confused.

I found it using the search bar to grab the old thread and this one popped up.

There have been some changes made to the YouTube embed code following the switch to YouTube's latest API. I'm on my phone right now so I can't give details here, but see paulgruberman's post in the Tech Team group for more information about it.

Zombie_Fish:
There have been some changes made to the YouTube embed code following the switch to YouTube's latest API. I'm on my phone right now so I can't give details here, but see paulgruberman's post in the Tech Team group for more information about it.

Hmm... either keep the old code where on computers we get both start and end features and mobile gets neither or move to the new code where both devices get start but neither get end.

I'll ask Paul about it.

Aerosteam:

Zombie_Fish:
There have been some changes made to the YouTube embed code following the switch to YouTube's latest API. I'm on my phone right now so I can't give details here, but see paulgruberman's post in the Tech Team group for more information about it.

Hmm... either keep the old code where on computers we get both start and end features and mobile gets neither or move to the new code where both devices get start but neither get end.

I'll ask Paul about it.

If you ask the Tech Team to add an end feature to the tag then they'll probably add it. Switching to the new API was a good thing to do anyway as the one that was being used before has now been declared deprecated by YouTube.

Zombie_Fish:

Aerosteam:

Zombie_Fish:
There have been some changes made to the YouTube embed code following the switch to YouTube's latest API. I'm on my phone right now so I can't give details here, but see paulgruberman's post in the Tech Team group for more information about it.

Hmm... either keep the old code where on computers we get both start and end features and mobile gets neither or move to the new code where both devices get start but neither get end.

I'll ask Paul about it.

If you ask the Tech Team to add an end feature to the tag then they'll probably add it. Switching to the new API was a good thing to do anyway as the one that was being used before has now been declared deprecated by YouTube.

It should work fine. The code is the same as it was last time (but a space instead of an ampersand, like the start function).

There's a really cool thing you can do with YouTube video resizing, and that's actually reducing its dimensions, just in case you don't want the video to be obstructive. Keeping the height at 30 pixels makes the embedding look like a music player!

Smallest it can be while keeping all functions:

[youtube=ei3-Qo9wHH4 height=30 width=290]


Mini version, and still be able to click the YouTube logo to go to the video's page:

[youtube=rbEBg7RU_SA height=30 width=107]


Smallest it can possibly be and have it still work:

[youtube=MkqSNS9va5k height=30 width=56]


A cool thing to use this in is some sort of role-playing threads we have here, it adds music to the thread while not make it look like crap.

Edit: Ugh, nevermind. YouTube changed their player so you can't do this anymore. -_-

Anyone have any details on how to embed escapist native videos on the site?

the [ video=] tag seems to be recognised as... Something. But I can't seem to figure out how to direct it at any particular video on the site...

CrystalShadow:
Anyone have any details on how to embed escapist native videos on the site?

the [ video=] tag seems to be recognised as... Something. But I can't seem to figure out how to direct it at any particular video on the site...

It used to be the ID of the video, e.g. this part

http://www.escapistmagazine.com/videos/view/zero-punctuation/57480-Gears-of-War-Ultimate-Edition-Review

However, it doesn't work any more. Dunno.

EDIT: Ignore that - it does work. I put this in and the latest Zero Punctuation was embedded

[video=57480]

Note that THE VIDEO PLAYS IMMEDIATELY.

EDIT 2: also - the video does not show up if you preview the post. Probably for the better, given that it would be very annoying

DoPo:
[video=57480]

Note that THE VIDEO PLAYS IMMEDIATELY.

Just put the whole tag in spoilers, and that solves that problem.

DoPo:

CrystalShadow:
Anyone have any details on how to embed escapist native videos on the site?

the [ video=] tag seems to be recognised as... Something. But I can't seem to figure out how to direct it at any particular video on the site...

It used to be the ID of the video, e.g. this part

http://www.escapistmagazine.com/videos/view/zero-punctuation/57480-Gears-of-War-Ultimate-Edition-Review

However, it doesn't work any more. Dunno.

EDIT: Ignore that - it does work. I put this in and the latest Zero Punctuation was embedded

[video=57480]

Note that THE VIDEO PLAYS IMMEDIATELY.

EDIT 2: also - the video does not show up if you preview the post. Probably for the better, given that it would be very annoying

IceForce:

DoPo:
[video=57480]

Note that THE VIDEO PLAYS IMMEDIATELY.

Just put the whole tag in spoilers, and that solves that problem.

Huh.
OK, that makes sense.
Also that it doesn't show up in previews also somewhat explains why it seemed so confusing.
Good to know.

This is... Oddly glitchy. Doesn't work for me at all, yet seems to work for some of you...
Very strange.

Update: Well, mystery solved, but that's one hell of an unfortunate combination.
1. Video autoplays.
2. Video doesn't show up in previews.
3. Video doesn't show up if you put it in a spoiler tag.

In other words, not much use unless you desperately want to drive people nuts.

DoPo:
[video=57480]

Note that THE VIDEO PLAYS IMMEDIATELY.

CrystalShadow:
1. Video autoplays.
2. Video doesn't show up in previews.
3. Video doesn't show up if you put it in a spoiler tag.

In other words, not much use unless you desperately want to drive people nuts.

I found a solution to the problem. Put "autoplay=0" inside the video tag, after the video number. Like so:

[ video=57427 autoplay=0]

(Code shamelessly stolen from here, by quoting the opening post.)

Though it has to be said, it's really odd that "autoplay=0" isn't the default.

IceForce:

DoPo:
[video=57480]

Note that THE VIDEO PLAYS IMMEDIATELY.

CrystalShadow:
1. Video autoplays.
2. Video doesn't show up in previews.
3. Video doesn't show up if you put it in a spoiler tag.

In other words, not much use unless you desperately want to drive people nuts.

I found a solution to the problem. Put "autoplay=0" inside the video tag, after the video number. Like so:

[ video=57427 autoplay=0]

(Code shamelessly stolen from here, by quoting the opening post.)

Though it has to be said, it's really odd that "autoplay=0" isn't the default.

Yeah. No kidding. You'd think they wouldn't want the primary association people have with the site's videos is getting seriously irritated at them. XD
Thanks though. Worth knowing.

Very pleasant surprise! Only regret I have is not asking for this to get stickied more than a year ago. So, uh, thanks to everyone who helped do that and very welcome to everyone who thinks this is a useful guide.

Does this site accept, or is it planning to ever accept, html code in the comments?

Epyc Wyn:
Does this site accept, or is it planning to ever accept, html code in the comments?

Technically it already does. Most of the codes that are explained in the OP are pretty much just basic html codes.

WHAT??? I was not aware the site accepted plain html code thank you for telling me! image

Anyone know if there's an Elapsed Time counter? I see that there's a count down timer... I wonder.

[et]2:55 08/02/2014[/et]

08/02/2014 09:55 AM GMT

Edit:
Well... ET doesn't work and timer using a past date doesn't work... blech

Generic NPC 22:
Anyone know if there's an Elapsed Time counter? I see that there's a count down timer... I wonder.

[et]2:55 08/02/2014[/et]

08/02/2014 09:55 AM GMT

Edit:
Well... ET doesn't work and timer using a past date doesn't work... blech

Here's the proper format for the countdown clock.
[ timer=04/17/2017 00:00 AM GMT]
It was literally the fifth section down in the OP. And of course it wont work on a date that's already passed as there's nothing to count down to.

Fijiman:

Generic NPC 22:
Anyone know if there's an Elapsed Time counter? I see that there's a count down timer... I wonder.

[et]2:55 08/02/2014[/et]

08/02/2014 09:55 AM GMT

Edit:
Well... ET doesn't work and timer using a past date doesn't work... blech

Here's the proper format for the countdown clock.
[ timer=04/17/2017 00:00 AM GMT]
It was literally the fifth section down in the OP. And of course it wont work on a date that's already passed as there's nothing to count down to.

Well Mister Fiji,

I understand the format for the count down timer but I was actually testing to see if it could be used to measure elapsed time since a specific date and time. I've found some obscure references for [ et]Time and Date[ /et] but I guess Escapist just doesn't utilize it. Oh well... back to searching the internet.

Does anyone remember how to embed the interactive badges into posts? I need it for... reasons.

vallorn:
Does anyone remember how to embed the interactive badges into posts? I need it for... reasons.

Right-click your badge, select 'copy image address', then paste that url within the code image with the url inbetween the quotes.

imageimageimageimageimage

Also, you can exploit this by doing this to the badge on my profile that when you select it, causes this entire web page to spin.

 Pages PREV 1 2

Reply to Thread

Log in or Register to Comment
Have an account? Login below:
With Facebook:Login With Facebook
or
Username:  
Password:  
  
Not registered? To sign up for an account with The Escapist:
Register With Facebook
Register With Facebook
or
Register for a free account here