The Escapist's Video Player - Feedback and Updates

 Pages 1 2 3 NEXT
 

Hello, everyone!

If you're having an issue with video not playing, please be sure to check out the video help page.

As you already know, last week we launched our brand new video player along side our new mobile site in an effort to make The Escapist more friendly for your mobile viewing. While the video player is definitely very shiny, like all new tech swag, it had a few bugs we've noticed thanks to the ample feedback provided by you and the community. Well, don't despair, because we are always listening to your feedback and have been working on optimizing the video player daily in order to provide you with the most seamless experience possible.

Here is an official forum thread to facilitate receiving your feedback on the new video player. It will also serve as a place where we can answer questions and concerns regarding it. We'll also be posting bug updates, so stay tuned for changes! If you have questions or concerns for the Tech Team not related to the video player, you can always post on the Tech Team Group or file a ticket.

Thank you for being awesome <3

Change log:

  • Fixed issue where failed response from ad server caused the player to fail to load
  • Reduced the amount background requests from the player

Last Week I inquired about a smaller video option. The technician said it will be installed by this week. This week and that option is still not available. So are you going to install one or was that a placation to shut me up?

malestrithe:
Last Week I inquired about a smaller video option. The technician said it will be installed by this week. This week and that option is still not available. So are you going to install one or was that a placation to shut me up?

Sorry this issue hasn't been fixed yet, I was hoping to get that out by this week but unfortunately other things popped up knocking this down on the list. You should expect this update shortly still as I have no forgotten about it.

So, the video player doesn't display the whatchumacallit, the thing with the play, stop, pause etc. buttons and the progress bar at all. Control panel? Video plays fine, just can't do anything except let it roll.

At the moment, I'm on a Mac/Safari combo, but I think it was like that when I was on a PC/Chrome too. Will check when I get back on muh PC. No third party junk whatsoever on either browser.

StatusNil:
So, the video player doesn't display the whatchumacallit, the thing with the play, stop, pause etc. buttons and the progress bar at all. Control panel? Video plays fine, just can't do anything except let it roll.

At the moment, I'm on a Mac/Safari combo, but I think it was like that when I was on a PC/Chrome too. Will check when I get back on muh PC. No third party junk whatsoever on either browser.

Got a full page screen shot I can see?

I'm not sure if this is petty or not, but could the video player [on the Pubclub side] not automatically start when the video's page is opened like how the old video player [on the PubClub end] used to do? The reason why I might consider this petty is because I liked keeping those video pages opened for later when I browse the Escapist using Chrome...

Thank you and sorry for my petty query...

ThyNameIsMud:

StatusNil:
So, the video player doesn't display the whatchumacallit, the thing with the play, stop, pause etc. buttons and the progress bar at all. Control panel? Video plays fine, just can't do anything except let it roll.

At the moment, I'm on a Mac/Safari combo, but I think it was like that when I was on a PC/Chrome too. Will check when I get back on muh PC. No third party junk whatsoever on either browser.

Got a full page screen shot I can see?

This is weird. I opened the same exact video (new Zero Punctuation) to take a screenshot, and now it IS there, perfectly functional. Yet I was sure enough it wasn't before to post a complaint. Also tried another video, that worked too.

It would appear I was wrong, or there was some transient issue on my end. Like the other day Escapist videos wouldn't play when I was logged in, worked when I wasn't. And then they worked fine later.

I'm sorry to have taken up your time with this. And thanks for the quick response.

StatusNil:
snip

Excellent, happy to hear everything is resolved.

FPLOON:
I'm not sure if this is petty or not, but could the video player [on the Pubclub side] not automatically start when the video's page is opened like how the old video player [on the PubClub end] used to do? The reason why I might consider this petty is because I liked keeping those video pages opened for later when I browse the Escapist using Chrome...

Thank you and sorry for my petty query...

Great suggestion, I'll add it to the feature request list.

The new player doesn't work. At all. Will you fix it, or should I stop coming here?

Joe Bonovich:
The new player doesn't work. At all. Will you fix it, or should I stop coming here?

I'm sorry to hear that. Could you be more specific on exactly what is not working for you so we can figure out what the issue is?

While I did have the largest screen ever for ZP videos, that was rectified moments after I found this thread. But now that I've had a day to think about things, all I can ask about is...

EDIT: OK, now for some mysterious reason, the problems that StatusNil, malestrithe and now Benedict Wolfe had/have are now back on my screen. PC with XP7, no third party shenaniganry and using Chrome here. I might update/improve these things one day when my financial situation doesn't involve throwing money at my piece of shit vehicle.

Updated VideoJS files from 4.6 -> 4.12

The video player won't let me skip to whichever part of the play through I choose: Whenever I click the progress bar or the progress marker the video pauses or unpauses.

The mobile site had a really rough start but it seems to be steadily improving over time. There are quite a few profile-oriented pages that are still a jumbled mess using a vertical view, though I am not sure how you could fix that without completely reformatting how it looks on mobile. Is that in the works at all?

Also, if you guys could figure out a way to show page count (and allow you to jump) from the forum screen that'd be terrific.

  • 2015-04-30 - Improved Layout of Mobile Player
  • 2015-04-30 - Added quality selector
  • 2015-04-30 - Updated Ad Plugin

Fappy:
The mobile site had a really rough start but it seems to be steadily improving over time. There are quite a few profile-oriented pages that are still a jumbled mess using a vertical view, though I am not sure how you could fix that without completely reformatting how it looks on mobile. Is that in the works at all?

Also, if you guys could figure out a way to show page count (and allow you to jump) from the forum screen that'd be terrific.

THIS IS A VIDEO FEEDBACK THREAD FAPPY

The profile pages largely need to rebuilt to make them responsive. It's deff on the to-do. Not sure what your second request means tho.

Benedict Wolfe:
The video player won't let me skip to whichever part of the play through I choose: Whenever I click the progress bar or the progress marker the video pauses or unpauses.

Should be fixed. let me know if it's still derped

For me, at least, now the videos won't even play. Shows the loading circle, but it just goes on and on like a never ending toilet swirly. When it does play, I'll letcha know if I can make it go to a certain time or not.

EDIT: For gits and shiggles, I clicked on the bar while it was still loading...and the time on the left side showed a -1:0-1.

Dunno if that might help troubleshoost things at all...

ThyNameIsMud:

Fappy:
The mobile site had a really rough start but it seems to be steadily improving over time. There are quite a few profile-oriented pages that are still a jumbled mess using a vertical view, though I am not sure how you could fix that without completely reformatting how it looks on mobile. Is that in the works at all?

Also, if you guys could figure out a way to show page count (and allow you to jump) from the forum screen that'd be terrific.

THIS IS A VIDEO FEEDBACK THREAD FAPPY

The profile pages largely need to rebuilt to make them responsive. It's deff on the to-do. Not sure what your second request means tho.

Yeah, I admit I worded it poorly. So like, let's say you navigate to "Gaming Discussion" on your phone and are browsing the list of threads on the front page. As of right now the mobile view does not include hyperlinks to individual pages of a thread like the full site view does. I realize that could be a real estate issue, but it would be nice to at least include the number of pages the thread contains.

Fappy:

ThyNameIsMud:

Fappy:
The mobile site had a really rough start but it seems to be steadily improving over time. There are quite a few profile-oriented pages that are still a jumbled mess using a vertical view, though I am not sure how you could fix that without completely reformatting how it looks on mobile. Is that in the works at all?

Also, if you guys could figure out a way to show page count (and allow you to jump) from the forum screen that'd be terrific.

THIS IS A VIDEO FEEDBACK THREAD FAPPY

The profile pages largely need to rebuilt to make them responsive. It's deff on the to-do. Not sure what your second request means tho.

Yeah, I admit I worded it poorly. So like, let's say you navigate to "Gaming Discussion" on your phone and are browsing the list of threads on the front page. As of right now the mobile view does not include hyperlinks to individual pages of a thread like the full site view does. I realize that could be a real estate issue, but it would be nice to at least include the number of pages the thread contains.

u messin' w/me?

image

CrazyCapnMorgan:
For me, at least, now the videos won't even play. Shows the loading circle, but it just goes on and on like a never ending toilet swirly. When it does play, I'll letcha know if I can make it go to a certain time or not.

EDIT: For gits and shiggles, I clicked on the bar while it was still loading...and the time on the left side showed a -1:0-1.

Dunno if that might help troubleshoost things at all...

Clear yo cache and try again. Just updated a bunch of core files about an hour ago

I'd like there to be an option to have the video player be the size it used to be. It's a small gripe, admittedly, and doesn't affect anything other than some convenience for me. Since I often have two windows open at once, I liked having the Escapist playing whatever video interested me while reading/answering emails or what have you. Again, nothing major, just a tad annoying. Other than that, the more pressing issues from launch day seem to have been ironed out on my end, so kudos.

ThyNameIsMud:

Fappy:

ThyNameIsMud:

THIS IS A VIDEO FEEDBACK THREAD FAPPY

The profile pages largely need to rebuilt to make them responsive. It's deff on the to-do. Not sure what your second request means tho.

Yeah, I admit I worded it poorly. So like, let's say you navigate to "Gaming Discussion" on your phone and are browsing the list of threads on the front page. As of right now the mobile view does not include hyperlinks to individual pages of a thread like the full site view does. I realize that could be a real estate issue, but it would be nice to at least include the number of pages the thread contains.

u messin' w/me?

image

Not the number of forum pages, the number of thread pages. Like this:

image

Fappy:

image

Ohhhhhh, yeah, it's a real estate issue. With only ~350 pixels of space to display so much information it requires a more thorough touch.

ThyNameIsMud:

Fappy:

image

Ohhhhhh, yeah, it's a real estate issue. With only ~350 pixels of space to display so much information it requires a more thorough touch.

Yeah, I figured as much. Silly phones, why dey so small?

ThyNameIsMud:

CrazyCapnMorgan:
For me, at least, now the videos won't even play. Shows the loading circle, but it just goes on and on like a never ending toilet swirly. When it does play, I'll letcha know if I can make it go to a certain time or not.

EDIT: For gits and shiggles, I clicked on the bar while it was still loading...and the time on the left side showed a -1:0-1.

Dunno if that might help troubleshoost things at all...

Clear yo cache and try again. Just updated a bunch of core files about an hour ago

Cleared and thankies a bunchies! I'd like to mirror King of Asgaard's request and also state that that is a minor thing for me, as well. Would be appreciated, though. ^_^

King of Asgaard:
I'd like there to be an option to have the video player be the size it used to be. It's a small gripe, admittedly, and doesn't affect anything other than some convenience for me. Since I often have two windows open at once, I liked having the Escapist playing whatever video interested me while reading/answering emails or what have you. Again, nothing major, just a tad annoying. Other than that, the more pressing issues from launch day seem to have been ironed out on my end, so kudos.

Yes, this one is next up on my list for requested features. Should expect it by early next week

  • 2015-05-01 - Player size toggle
  • 2015-05-01 - Volume will now be persistent
  • 2015-05-01 - Player can now remember users preferences via cookie

malestrithe:
Last Week I inquired about a smaller video option. The technician said it will be installed by this week. This week and that option is still not available. So are you going to install one or was that a placation to shut me up?

King of Asgaard:
I'd like there to be an option to have the video player be the size it used to be. It's a small gripe, admittedly, and doesn't affect anything other than some convenience for me. Since I often have two windows open at once, I liked having the Escapist playing whatever video interested me while reading/answering emails or what have you. Again, nothing major, just a tad annoying. Other than that, the more pressing issues from launch day seem to have been ironed out on my end, so kudos.

CrazyCapnMorgan:
Cleared and thankies a bunchies! I'd like to mirror King of Asgaard's request and also state that that is a minor thing for me, as well. Would be appreciated, though. ^_^

There's an option on the bottom menu 'Small Player'. Choice will remain persistent for logged in users.

ThyNameIsMud:

malestrithe:
Last Week I inquired about a smaller video option. The technician said it will be installed by this week. This week and that option is still not available. So are you going to install one or was that a placation to shut me up?

King of Asgaard:
I'd like there to be an option to have the video player be the size it used to be. It's a small gripe, admittedly, and doesn't affect anything other than some convenience for me. Since I often have two windows open at once, I liked having the Escapist playing whatever video interested me while reading/answering emails or what have you. Again, nothing major, just a tad annoying. Other than that, the more pressing issues from launch day seem to have been ironed out on my end, so kudos.

CrazyCapnMorgan:
Cleared and thankies a bunchies! I'd like to mirror King of Asgaard's request and also state that that is a minor thing for me, as well. Would be appreciated, though. ^_^

There's an option on the bottom menu 'Small Player'. Choice will remain persistent for logged in users.

Doing God's work, mate. Just tested it on the latest Zero Punctuation and it worked like a charm. Cheers on getting to it so quickly.

ThyNameIsMud:

malestrithe:
Last Week I inquired about a smaller video option. The technician said it will be installed by this week. This week and that option is still not available. So are you going to install one or was that a placation to shut me up?

King of Asgaard:
I'd like there to be an option to have the video player be the size it used to be. It's a small gripe, admittedly, and doesn't affect anything other than some convenience for me. Since I often have two windows open at once, I liked having the Escapist playing whatever video interested me while reading/answering emails or what have you. Again, nothing major, just a tad annoying. Other than that, the more pressing issues from launch day seem to have been ironed out on my end, so kudos.

CrazyCapnMorgan:
Cleared and thankies a bunchies! I'd like to mirror King of Asgaard's request and also state that that is a minor thing for me, as well. Would be appreciated, though. ^_^

There's an option on the bottom menu 'Small Player'. Choice will remain persistent for logged in users.

Just got home to see this message. Tested and worked! Thank ya, Mud!

ThyNameIsMud:

Benedict Wolfe:
The video player won't let me skip to whichever part of the play through I choose: Whenever I click the progress bar or the progress marker the video pauses or unpauses.

Should be fixed. let me know if it's still derped

It's still bugged for me. Really annoying =(
Chrome (add-on free), 1440x900 and windowed as well.

glider:

ThyNameIsMud:

Benedict Wolfe:
The video player won't let me skip to whichever part of the play through I choose: Whenever I click the progress bar or the progress marker the video pauses or unpauses.

Should be fixed. let me know if it's still derped

It's still bugged for me. Really annoying =(
Chrome (add-on free), 1440x900 and windowed as well.

Mine Too

glider:
Snip

IkemEverburn:
Snip

Apologies for the issues you're having however I'm going to need more information from y'all in order to figure out issues you're having.

  • What OS/Browser Combo are you using?
  • Having the same issue with different browsers? Computer? Devices?
  • Can you show me a full page screen shot of this not working? It seems silly to ask for this considering the nature of the bug but trust me when I say it helps.
  • Are you blocking something with your host file?
  • Just to be sure, you cleared your cookies/cache and tried again?

With the above information I can attempt to track down where these issues are.

 Pages 1 2 3 NEXT

Reply to Thread

Log in or Register to Comment
Have an account? Login below:
With Facebook:Login With Facebook
or
Username:  
Password:  
  
Not registered? To sign up for an account with The Escapist:
Register With Facebook
Register With Facebook
or
Register for a free account here